Sha-256セキュリティアップグレード


#1

11月5日更新: 11月4日(US時間、水曜日)のサーバ側作業は予定通り完了しました。

2015年11月4日(US時間)に、AmazonマーケットプレイスWebサービス (Amazon MWS)のすべてのセキュリティ保護されたエンドポイントをアップグレードして、SSL/TLSによる接続の際にSHA-256互換性が必要となります。

クライアントライブラリの互換性

エンドポイントとの接続互換性を保証するために、クライアントライブラリをご使用の際には以下のバージョンのソフトウェアが必要になります。

Java: JDK 1.6.0_19またはそれ以降
PHP: OpenSSL 0.9.8oまたはそれ以降
C#: 特にありません

ブラウザの互換性

ブラウザからAmazon MWS Webサイトへの接続に問題がある場合は、ブラウザを最新のバージョンにアップグレードしてください。

SHA-256に関する情報は、AWS to Switch to SHA256 Hash Algorithm for SSL Certificatesをご参照ください。SHA-256互換性を確認する際に利用できるサンプルプログラムをダウンロードすることができます。


closed #2

unlisted #3